package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bhttp:\/\/[a-zA-Z0-9]{1,}\.com\/(([a-zA-Z0-9]{1,}\/){1,})?(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$`)
var str = `http://site.com/folder/1/2/asd/sdasd/1.png
file.png
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}