using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bhttp:\/\/[a-zA-Z0-9]{1,}\.com\/(([a-zA-Z0-9]{1,}\/){1,})?(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$";
string input = @"http://site.com/folder/1/2/asd/sdasd/1.png
file.png
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}