re = /(^(?:https?:\/\/)?(?:[^\/]*))/m
str = 'www.domain.com/testing/something
https://www.site.com/testing
https://test.com/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end