$re = '#(^(?:https?://)?(?:[^/]*))#m';
$str = 'www.domain.com/testing/something
https://www.site.com/testing
https://test.com/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);