re = / $scope.passwordRegex2 = ^(?=.*[^a-zA-Z0-9`~!@#$%^&*()-=_+,.<>?;':"\[\]{}\\|]).{1,150}$
/mix
str = '5265736f75726365206964202334
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end