$re = '/ $scope.passwordRegex2 = ^(?=.*[^a-zA-Z0-9`~!@#$%^&*()-=_+,.<>?;\':"\[\]{}\\\\|]).{1,150}$
/mixXsuUAJD';
$str = '5265736f75726365206964202334
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);