$re = '/^[^iIoOqQsSxXzZ0-9]{1}$/m';
$str = 'a
b
c
q
Q
s
t
Tttt
1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);