re = /^(?s)(?P<time>\S+?) (?P<stream>stdout|stderr) (?P<flags>\S+?) (?P<content>.*)$/m
str = '2019-01-01T01:00:00.000000001Z stderr P some log message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end