package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^(?s)(?P<time>\S+?) (?P<stream>stdout|stderr) (?P<flags>\S+?) (?P<content>.*)$`)
var str = `2019-01-01T01:00:00.000000001Z stderr P some log message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}