import Foundation
let pattern = #"^SW(TS|L|M)-(\d+)([:,] )([wW][iI][pP])?(?(4)[ \w]{3,}|(?!([wW][iI][pP]))[ \w]{3,}).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SWL-101
just did it
SWL-101: wip something is about to be done
SWL-102: wip
SWTS-103, we did something cool
SWM-104, i am groot!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)