import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^SW(TS|L|M)-(\\d+)([:,] )([wW][iI][pP])?(?(4)[ \\w]{3,}|(?!([wW][iI][pP]))[ \\w]{3,}).*$";
final String string = "SWL-101\n"
+ "just did it\n"
+ "SWL-101: wip something is about to be done\n"
+ "SWL-102: wip \n"
+ "SWTS-103, we did something cool\n"
+ "SWM-104, i am groot!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}