// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(xn[-]{2,})?(.*)(\..*)$").unwrap();
let string = "domain2=@_.com
my-domain3?$.com
my---domain3?$.com
!:domain3?$.com
;,どるdomain7.com
&)どるdomain6^`.com
5)my$$$domain4.com
**my--domain5--.com
**my--do--main8--.com
**my---do--main8--.com
xn-$domain15--.com
xn-$do--main11--.com
xn$$do--main12--.com
ろれっくす.club
xn--domain13--.com
xn---domain14--.com
xn--ztt861f.xn--rhqv96g
xn-----7i8a8a5job0h.xn--1ck2e1b
xn-----5i4a8a4job0h.xn--1ck2e1b
xn-----3i4a8c4hob1h.xn--1ck2e1b
xn-----3i4a8c4hob1h.xo
xn--do--main9--.xn--gdfkg5454--4cx54----)à-è)-(àfglkdfkgldk
xn---do--main10--.com
xn--domain6`.xn--com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}