# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(xn[-]{2,})?(.*)(\..*)$"
test_str = ("domain2=@_.com\n"
"my-domain3?$.com\n"
"my---domain3?$.com\n"
"!:domain3?$.com\n"
";,どるdomain7.com\n"
"&)どるdomain6^`.com\n"
"5)my$$$domain4.com\n"
"**my--domain5--.com\n"
"**my--do--main8--.com\n"
"**my---do--main8--.com\n"
"xn-$domain15--.com\n"
"xn-$do--main11--.com\n"
"xn$$do--main12--.com\n"
"ろれっくす.club\n\n"
"xn--domain13--.com\n"
"xn---domain14--.com\n"
"xn--ztt861f.xn--rhqv96g\n"
"xn-----7i8a8a5job0h.xn--1ck2e1b\n"
"xn-----5i4a8a4job0h.xn--1ck2e1b\n"
"xn-----3i4a8c4hob1h.xn--1ck2e1b\n"
"xn-----3i4a8c4hob1h.xo\n"
"xn--do--main9--.xn--gdfkg5454--4cx54----)à-è)-(àfglkdfkgldk\n"
"xn---do--main10--.com\n"
"xn--domain6`.xn--com\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.