re = /^[A-Za-z]-.*$|^[A-Za-z]\s.*$/
str = 'CASE
regexp_replace (od_proposed,\'^[A-Za-z]-.*$\',\'^[A-Za-z]-\\d$\')
regexp_replace (od,\'^[A-Za-z]\\s.*$\',\'^[A-Za-z]\')
A-1 - AIRPLANE
A-2 - AIRPLANE
A-3 - AIRPLANE
A-4 - AIRPLANE
A-5 - AIRPLANE
B - BOARD ROOM
E - EMERGENCY: FIRST ROOM
F-1 - FIRST
F-2 - FIRST
H-1 - HOUSING
H-2 - HOUSING
H-3 - HOUSING
H-4 - HOUSING
I-1 - INITIAL
I-2 - INITIAL
I-3 - INITIAL
I-4 - INITIAL
M - MASTER
R-1 - REASON
R-2 - REASON
R-3 - REASON
S-1 - SHORTCUT: TO CAFE
S-2 - SHORTCUT: TO CAFE
U - UTILITY'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end