#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[A-Za-z]-.*$|^[A-Za-z]\s.*$"
Local $sString = "CASE" & @CRLF & _
"regexp_replace (od_proposed,'^[A-Za-z]-.*$','^[A-Za-z]-\d$')" & @CRLF & _
"regexp_replace (od,'^[A-Za-z]\s.*$','^[A-Za-z]')" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"A-1 - AIRPLANE" & @CRLF & _
"A-2 - AIRPLANE" & @CRLF & _
"A-3 - AIRPLANE" & @CRLF & _
"A-4 - AIRPLANE" & @CRLF & _
"A-5 - AIRPLANE" & @CRLF & _
"B - BOARD ROOM" & @CRLF & _
"E - EMERGENCY: FIRST ROOM" & @CRLF & _
"F-1 - FIRST " & @CRLF & _
"F-2 - FIRST " & @CRLF & _
"H-1 - HOUSING" & @CRLF & _
"H-2 - HOUSING" & @CRLF & _
"H-3 - HOUSING" & @CRLF & _
"H-4 - HOUSING" & @CRLF & _
"I-1 - INITIAL" & @CRLF & _
"I-2 - INITIAL" & @CRLF & _
"I-3 - INITIAL" & @CRLF & _
"I-4 - INITIAL" & @CRLF & _
"M - MASTER" & @CRLF & _
"R-1 - REASON" & @CRLF & _
"R-2 - REASON" & @CRLF & _
"R-3 - REASON" & @CRLF & _
"S-1 - SHORTCUT: TO CAFE" & @CRLF & _
"S-2 - SHORTCUT: TO CAFE" & @CRLF & _
"U - UTILITY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")