# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<prm>\w+)\s+.*:\s*=\s*'(?<tbl>\w+)'\s*;(?:.|\n)*(?:alter|create)\s+table\s+'\s*\|\|\s*(\k<prm>\s+)"
test_str = ("DECLARE\n"
"COUNTER NUMBER(10) := 0;\n"
"pTABLENAME VARCHAR2(100) := 'ALM_AL1';\n"
"pCOLUMNNAME VARCHAR2(100) := 'FLOATACCRUALDCBASISDAYC';\n"
"pDATATYPE VARCHAR2(100) := 'NVARCHAR2(50) NULL';\n"
"pSQL VARCHAR2(32000) := '\n"
"ALTER TABLE ' || pTABLENAME || ' ADD ' || pCOLUMNNAME || ' ' || pDATATYPE;\n"
"BEGIN\n"
" SELECT COUNT(0) INTO COUNTER FROM USER_TAB_COLUMNS WHERE TABLE_NAME=UPPER(pTABLENAME) AND COLUMN_NAME=UPPER(pCOLUMNNAME);\n"
" IF COUNTER>0 THEN\n"
" dbms_output.put_line(pTABLENAME || ' tablosunda ' || pCOLUMNNAME || ' kolonu var.');\n"
" ELSE\n"
" EXECUTE IMMEDIATE pSQL;\n"
" dbms_output.put_line(pTABLENAME || ' tablosuna' || pCOLUMNNAME || ' kolonu oluÅ?turuldu.');\n"
" END IF;\n"
" \n"
" EXCEPTION\n"
" WHEN OTHERS THEN\n"
" dbms_output.put_line('HATA: ' || pSQL || ' -> SQLERRM: ' || SQLERRM);\n"
"END;\n"
"/\n\n"
"DECLARE\n"
"COUNTER NUMBER(10) := 0;\n"
"pTABLENAME VARCHAR2(100) := 'ALM_AL2';\n"
"pCOLUMNNAME VARCHAR2(100) := 'RATETYPETYPE';\n"
"pDATATYPE VARCHAR2(100) := 'NVARCHAR2(40) NULL';\n"
"pSQL VARCHAR2(32000) := '\n"
"ALTER TABLE ' || pTABLENAME || ' ADD ' || pCOLUMNNAME || ' ' || pDATATYPE;\n"
"BEGIN\n"
" SELECT COUNT(0) INTO COUNTER FROM USER_TAB_COLUMNS WHERE TABLE_NAME=UPPER(pTABLENAME) AND COLUMN_NAME=UPPER(pCOLUMNNAME);\n"
" IF COUNTER>0 THEN\n"
" dbms_output.put_line(pTABLENAME || ' tablosunda ' || pCOLUMNNAME || ' kolonu var.');\n"
" ELSE\n"
" EXECUTE IMMEDIATE pSQL;\n"
" dbms_output.put_line(pTABLENAME || ' tablosuna' || pCOLUMNNAME || ' kolonu oluÅ?turuldu.');\n"
" END IF;\n"
" \n"
" EXCEPTION\n"
" WHEN OTHERS THEN\n"
" dbms_output.put_line('HATA: ' || pSQL || ' -> SQLERRM: ' || SQLERRM);\n"
"END;\n"
"/\n\n"
"DECLARE\n"
"COUNTER NUMBER(10) := 0;\n"
"pTABLENAME VARCHAR2(100) := 'ALM_AL3';\n"
"pCOLUMNNAME VARCHAR2(100) := 'PAYCURRENCYUNIT';\n"
"pDATATYPE VARCHAR2(100) := 'NVARCHAR2(3) NULL';\n"
"pSQL VARCHAR2(32000) := '\n"
"ALTER TABLE ' || pTABLENAME || ' ADD ' || pCOLUMNNAME || ' ' || pDATATYPE;\n"
"BEGIN\n"
" SELECT COUNT(0) INTO COUNTER FROM USER_TAB_COLUMNS WHERE TABLE_NAME=UPPER(pTABLENAME) AND COLUMN_NAME=UPPER(pCOLUMNNAME);\n"
" IF COUNTER>0 THEN\n"
" dbms_output.put_line(pTABLENAME || ' tablosunda ' || pCOLUMNNAME || ' kolonu var.');\n"
" ELSE\n"
" EXECUTE IMMEDIATE pSQL;\n"
" dbms_output.put_line(pTABLENAME || ' tablosuna' || pCOLUMNNAME || ' kolonu oluÅ?turuldu.');\n"
" END IF;\n"
" \n"
" EXCEPTION\n"
" WHEN OTHERS THEN\n"
" dbms_output.put_line('HATA: ' || pSQL || ' -> SQLERRM: ' || SQLERRM);\n"
"END;\n"
"/")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.