#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iU)(?<prm>\w+)\s+.*:\s*=\s*'(?<tbl>\w+)'\s*;(?:.|\n)*(?:alter|create)\s+table\s+'\s*\|\|\s*(\k<prm>\s+)"
Local $sString = "DECLARE" & @CRLF & _
"COUNTER NUMBER(10) := 0;" & @CRLF & _
"pTABLENAME VARCHAR2(100) := 'ALM_AL1';" & @CRLF & _
"pCOLUMNNAME VARCHAR2(100) := 'FLOATACCRUALDCBASISDAYC';" & @CRLF & _
"pDATATYPE VARCHAR2(100) := 'NVARCHAR2(50) NULL';" & @CRLF & _
"pSQL VARCHAR2(32000) := '" & @CRLF & _
"ALTER TABLE ' || pTABLENAME || ' ADD ' || pCOLUMNNAME || ' ' || pDATATYPE;" & @CRLF & _
"BEGIN" & @CRLF & _
" SELECT COUNT(0) INTO COUNTER FROM USER_TAB_COLUMNS WHERE TABLE_NAME=UPPER(pTABLENAME) AND COLUMN_NAME=UPPER(pCOLUMNNAME);" & @CRLF & _
" IF COUNTER>0 THEN" & @CRLF & _
" dbms_output.put_line(pTABLENAME || ' tablosunda ' || pCOLUMNNAME || ' kolonu var.');" & @CRLF & _
" ELSE" & @CRLF & _
" EXECUTE IMMEDIATE pSQL;" & @CRLF & _
" dbms_output.put_line(pTABLENAME || ' tablosuna' || pCOLUMNNAME || ' kolonu oluÅ?turuldu.');" & @CRLF & _
" END IF;" & @CRLF & _
" " & @CRLF & _
" EXCEPTION" & @CRLF & _
" WHEN OTHERS THEN" & @CRLF & _
" dbms_output.put_line('HATA: ' || pSQL || ' -> SQLERRM: ' || SQLERRM);" & @CRLF & _
"END;" & @CRLF & _
"/" & @CRLF & _
"" & @CRLF & _
"DECLARE" & @CRLF & _
"COUNTER NUMBER(10) := 0;" & @CRLF & _
"pTABLENAME VARCHAR2(100) := 'ALM_AL2';" & @CRLF & _
"pCOLUMNNAME VARCHAR2(100) := 'RATETYPETYPE';" & @CRLF & _
"pDATATYPE VARCHAR2(100) := 'NVARCHAR2(40) NULL';" & @CRLF & _
"pSQL VARCHAR2(32000) := '" & @CRLF & _
"ALTER TABLE ' || pTABLENAME || ' ADD ' || pCOLUMNNAME || ' ' || pDATATYPE;" & @CRLF & _
"BEGIN" & @CRLF & _
" SELECT COUNT(0) INTO COUNTER FROM USER_TAB_COLUMNS WHERE TABLE_NAME=UPPER(pTABLENAME) AND COLUMN_NAME=UPPER(pCOLUMNNAME);" & @CRLF & _
" IF COUNTER>0 THEN" & @CRLF & _
" dbms_output.put_line(pTABLENAME || ' tablosunda ' || pCOLUMNNAME || ' kolonu var.');" & @CRLF & _
" ELSE" & @CRLF & _
" EXECUTE IMMEDIATE pSQL;" & @CRLF & _
" dbms_output.put_line(pTABLENAME || ' tablosuna' || pCOLUMNNAME || ' kolonu oluÅ?turuldu.');" & @CRLF & _
" END IF;" & @CRLF & _
" " & @CRLF & _
" EXCEPTION" & @CRLF & _
" WHEN OTHERS THEN" & @CRLF & _
" dbms_output.put_line('HATA: ' || pSQL || ' -> SQLERRM: ' || SQLERRM);" & @CRLF & _
"END;" & @CRLF & _
"/" & @CRLF & _
"" & @CRLF & _
"DECLARE" & @CRLF & _
"COUNTER NUMBER(10) := 0;" & @CRLF & _
"pTABLENAME VARCHAR2(100) := 'ALM_AL3';" & @CRLF & _
"pCOLUMNNAME VARCHAR2(100) := 'PAYCURRENCYUNIT';" & @CRLF & _
"pDATATYPE VARCHAR2(100) := 'NVARCHAR2(3) NULL';" & @CRLF & _
"pSQL VARCHAR2(32000) := '" & @CRLF & _
"ALTER TABLE ' || pTABLENAME || ' ADD ' || pCOLUMNNAME || ' ' || pDATATYPE;" & @CRLF & _
"BEGIN" & @CRLF & _
" SELECT COUNT(0) INTO COUNTER FROM USER_TAB_COLUMNS WHERE TABLE_NAME=UPPER(pTABLENAME) AND COLUMN_NAME=UPPER(pCOLUMNNAME);" & @CRLF & _
" IF COUNTER>0 THEN" & @CRLF & _
" dbms_output.put_line(pTABLENAME || ' tablosunda ' || pCOLUMNNAME || ' kolonu var.');" & @CRLF & _
" ELSE" & @CRLF & _
" EXECUTE IMMEDIATE pSQL;" & @CRLF & _
" dbms_output.put_line(pTABLENAME || ' tablosuna' || pCOLUMNNAME || ' kolonu oluÅ?turuldu.');" & @CRLF & _
" END IF;" & @CRLF & _
" " & @CRLF & _
" EXCEPTION" & @CRLF & _
" WHEN OTHERS THEN" & @CRLF & _
" dbms_output.put_line('HATA: ' || pSQL || ' -> SQLERRM: ' || SQLERRM);" & @CRLF & _
"END;" & @CRLF & _
"/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")