using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*\n){2}";
string substitution = @"";
string input = @"LINE1
LINE2
LINE3
LINE4
LINE5
LINE6
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}