re = /^(((\+|00)?(90)|0)[-| ]?)?((5\d{2})[-| ]?(\d{3})[-| ]?(\d{2})[-| ]?(\d{2}))$/m
str = '555-123-45-67
0 555 123 45 67
+905551234567
00905551234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end