import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\+|00)?(90)|0)[-| ]?)?((5\\d{2})[-| ]?(\\d{3})[-| ]?(\\d{2})[-| ]?(\\d{2}))$";
final String string = "555-123-45-67\n"
+ "0 555 123 45 67\n"
+ "+905551234567\n"
+ "00905551234567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}