re = /^(?!(.*看.*|.*听.*)).*斗地主(?!.*电影|.*电视剧|.*音乐|.*歌|.*综艺|.*动漫|.*动画片).*/m
str = '你爸爸是谁'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end