$re = '/^(?!(.*看.*|.*听.*)).*斗地主(?!.*电影|.*电视剧|.*音乐|.*歌|.*综艺|.*动漫|.*动画片).*/m';
$str = '你爸爸是谁';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);