re = /(00|1|(01|10)((00)*|1*)(0|01*))/m
str = '00
1
01000
1011101
0111100001110
0101
010
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end