$re = '/(00|1|(01|10)((00)*|1*)(0|01*))/m';
$str = '00
1
01000
1011101
0111100001110
0101
010
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);