import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?im)^(?<c1>\\\"?)\\w+(?:[\\W&&[^@]]?)\\w+\\k<c1>@(?:\\[?(?:\\d{3}\\.?){0,4}\\]?|(?:[\\w&&[^\\d]]+[\\.\\-]?)*(?<=\\.\\w{2,6}))$";
final String string = "List of Valid Email Addresses\n\n"
+ "email@example.com\n"
+ "firstname.lastname@example.com\n"
+ "email@subdomain.example.com\n"
+ "firstname+lastname@example.com\n"
+ "email@123.123.123.123\n"
+ "email@[123.123.123.123]\n"
+ "\"email\"@example.com\n"
+ "1234567890@example.com\n"
+ "email@example-one.com\n"
+ "_______@example.com\n"
+ "email@example.name\n"
+ "email@example.museum\n"
+ "email@example.co.jp\n"
+ "firstname-lastname@example.com\n\n\n\n"
+ "List of Strange Valid Email Addresses\n\n"
+ "much.”more\\ unusual”@example.com\n"
+ "very.unusual.”@”.unusual.com@example.com\n"
+ "very.”(),:;<>[]”.VERY.”very@\\\\ \"very”.unusual@strange.example.com\n\n\n\n"
+ "List of Invalid Email Addresses\n\n"
+ "plainaddress\n"
+ "#@%^%#$@#$@#.com\n"
+ "@example.com\n"
+ "Joe Smith <email@example.com>\n"
+ "email.example.com\n"
+ "email@example@example.com\n"
+ ".email@example.com\n"
+ "email.@example.com\n"
+ "email..email@example.com\n"
+ "あいうえお@example.com\n"
+ "email@example.com (Joe Smith)\n"
+ "email@example\n"
+ "email@-example.com\n"
+ "email@example.web\n"
+ "email@111.222.333.44444\n"
+ "email@example..com\n"
+ "Abc..123@example.com\n\n\n\n"
+ "List of Strange Invalid Email Addresses\n\n"
+ "”(),:;<>[\\]@example.com\n"
+ "just”not”right@example.com\n"
+ "this\\ is\"really\"not\\allowed@example.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}