#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?<c1>\"?)\w+(?:[\W&&[^@]]?)\w+\k<c1>@(?:\[?(?:\d{3}\.?){0,4}\]?|(?:[\w&&[^\d]]+[\.\-]?)*(?<=\.\w{2,6}))$"
Local $sString = "List of Valid Email Addresses" & @CRLF & _
"" & @CRLF & _
"email@example.com" & @CRLF & _
"firstname.lastname@example.com" & @CRLF & _
"email@subdomain.example.com" & @CRLF & _
"firstname+lastname@example.com" & @CRLF & _
"email@123.123.123.123" & @CRLF & _
"email@[123.123.123.123]" & @CRLF & _
""email"@example.com" & @CRLF & _
"1234567890@example.com" & @CRLF & _
"email@example-one.com" & @CRLF & _
"_______@example.com" & @CRLF & _
"email@example.name" & @CRLF & _
"email@example.museum" & @CRLF & _
"email@example.co.jp" & @CRLF & _
"firstname-lastname@example.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"List of Strange Valid Email Addresses" & @CRLF & _
"" & @CRLF & _
"much.”more\ unusual”@example.com" & @CRLF & _
"very.unusual.”@”.unusual.com@example.com" & @CRLF & _
"very.”(),:;<>[]”.VERY.”very@\\ "very”.unusual@strange.example.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"List of Invalid Email Addresses" & @CRLF & _
"" & @CRLF & _
"plainaddress" & @CRLF & _
"#@%^%#$@#$@#.com" & @CRLF & _
"@example.com" & @CRLF & _
"Joe Smith <email@example.com>" & @CRLF & _
"email.example.com" & @CRLF & _
"email@example@example.com" & @CRLF & _
".email@example.com" & @CRLF & _
"email.@example.com" & @CRLF & _
"email..email@example.com" & @CRLF & _
"あいうえお@example.com" & @CRLF & _
"email@example.com (Joe Smith)" & @CRLF & _
"email@example" & @CRLF & _
"email@-example.com" & @CRLF & _
"email@example.web" & @CRLF & _
"email@111.222.333.44444" & @CRLF & _
"email@example..com" & @CRLF & _
"Abc..123@example.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"List of Strange Invalid Email Addresses" & @CRLF & _
"" & @CRLF & _
"”(),:;<>[\]@example.com" & @CRLF & _
"just”not”right@example.com" & @CRLF & _
"this\ is"really"not\allowed@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")