import Foundation
let pattern = #""Id":"(?<campid>.*?)","Status":"(?<status>.*?)","Five9__Five9list__c":"(?<five9list>.*?)"}]}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"searchRecords":[{"attributes":{"type":"Campaign","url":"/services/data/v43.0/sobjects/Campaign/701C0000000sVOVIA2"},"Id":"701C0000000sVOVIA2","Status":"Planned","Five9__Five9list__c":"Toast_list_outbound"}]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)