re = /"Id":"(?<campid>.*?)","Status":"(?<status>.*?)","Five9__Five9list__c":"(?<five9list>.*?)"}]}/m
str = '{"searchRecords":[{"attributes":{"type":"Campaign","url":"/services/data/v43.0/sobjects/Campaign/701C0000000sVOVIA2"},"Id":"701C0000000sVOVIA2","Status":"Planned","Five9__Five9list__c":"Toast_list_outbound"}]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end