$re = '/\d{1,2}/';
$str = '12 1 2 3 4 5 6 7 8 9 11 15 21';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);