package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,2}`)
var str = `12 1 2 3 4 5 6 7 8 9 11 15 21`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}