package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\<([0-9]{1,3})\>([A-Za-z]{3} [0-9]{1,2} \d{2}:\d{2}:\d{2}) ([\S]+) ([\S\s]+)`)
var str = `<131>Jan 23 17:05:05 rdmlpavesi1d gs-rest-service error message slf4j thread:http-nio-8080-exec-1 priority:ERROR category:command.AppSyslogd.Application exception:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}