$re = '/([a-z]|[A-Z]|[0-9]){6,10}/m';
$str = 'E2j1tT3YHn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);