package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]|[A-Z]|[0-9]){6,10}`)
var str = `E2j1tT3YHn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}