$re = '/^(([0-9]+)([\t ]*\-[\t ]*([0-9]+))?)([\w\t ]*)$/u';
$str = '50 - 55 Autolikes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);