package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([0-9]+)([\t ]*\-[\t ]*([0-9]+))?)([\w\t ]*)$`)
var str = `50 - 55 Autolikes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}