re = /^[a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+@unal\.edu\.co/m
str = 'test@unal.edu.co'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end