package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9.!#$%&'*+/=?^_`{|}~-]+@unal\.edu\.co`)
var str = `test@unal.edu.co`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}