const regex = /^([\S+]{3}\s+[\S+]{3}\s+[\d+]{2}\s+[\d+]{2}:[\d+]{2}:{0,2}:[\d+]{2}:{0,2}\s+[\d+]{0,4})\s+(\/[\S+]*)\s+([\S+*\s+]*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\S+]{3}\\s+[\\S+]{3}\\s+[\\d+]{2}\\s+[\\d+]{2}:[\\d+]{2}:{0,2}:[\\d+]{2}:{0,2}\\s+[\\d+]{0,4})\\s+(\\\/[\\S+]*)\\s+([\\S+*\\s+]*)', 'gmi')
const str = `Mon Dec 31 01:51:15 2018 /Users/fractal/Developer/Projects/wiki/app/User.php Renamed OwnerModified IsFile`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}