import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\S+]{3}\\s+[\\S+]{3}\\s+[\\d+]{2}\\s+[\\d+]{2}:[\\d+]{2}:{0,2}:[\\d+]{2}:{0,2}\\s+[\\d+]{0,4})\\s+(\\/[\\S+]*)\\s+([\\S+*\\s+]*)";
final String string = "Mon Dec 31 01:51:15 2018 /Users/fractal/Developer/Projects/wiki/app/User.php Renamed OwnerModified IsFile";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}