$re = '/([A-z\d-\/_.]+)?/';
$str = 'Path1/With-Char/With_Char/WithNumbers-0123456789/with.character';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);