const regex = /([A-z\d-\/_.]+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-z\\d-\\\/_.]+)?', 'g')
const str = `Path1/With-Char/With_Char/WithNumbers-0123456789/with.character`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}