import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((to|mon|tues|wed(nes)?|thur(s)?|fri|sat(ur)?|sun)(day)?)?|\\d(\\d?)(:\\d\\d)?(p|a)m";
final String string = "1:00, 1pm, 1:00pm, noon, 11:30am, 1130am\n"
+ "1pm wednesday\n"
+ "wednesday\n"
+ "tomorrow at noon\n"
+ "today at 11\n"
+ "hot dog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}