#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b((to|mon|tues|wed(nes)?|thur(s)?|fri|sat(ur)?|sun)(day)?)?|\d(\d?)(:\d\d)?(p|a)m"
Local $sString = "1:00, 1pm, 1:00pm, noon, 11:30am, 1130am" & @CRLF & _
"1pm wednesday" & @CRLF & _
"wednesday" & @CRLF & _
"tomorrow at noon" & @CRLF & _
"today at 11" & @CRLF & _
"hot dog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")