import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(?:M{1,4})?(?:CM|CD|D?C{1,3})?(?:XC|XL|L?X{1,3})?(?:IX|IV|V?I{1,3})?\\b)";
final String string = "VII\n"
+ "CMXL\n"
+ "XII\n"
+ "XVII\n"
+ "IV\n"
+ "MMMIII\n"
+ "MXI\n"
+ "MXIV\n"
+ "MM\n"
+ "MC\n"
+ "MM\n"
+ "I\n"
+ "VI\n"
+ "MX\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}