#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\b(?:M{1,4})?(?:CM|CD|D?C{1,3})?(?:XC|XL|L?X{1,3})?(?:IX|IV|V?I{1,3})?\b)"
Local $sString = "VII" & @CRLF & _
"CMXL" & @CRLF & _
"XII" & @CRLF & _
"XVII" & @CRLF & _
"IV" & @CRLF & _
"MMMIII" & @CRLF & _
"MXI" & @CRLF & _
"MXIV" & @CRLF & _
"MM" & @CRLF & _
"MC" & @CRLF & _
"MM" & @CRLF & _
"I" & @CRLF & _
"VI" & @CRLF & _
"MX" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")