# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?:[A-Za-z]\d ?\d[A-Za-z]{2})|(?:[A-Za-z][A-Za-z\d]\d ?\d[A-Za-z]{2})|(?:[A-Za-z]{2}\d{2} ?\d[A-Za-z]{2})|(?:[A-Za-z]\d[A-Za-z] ?\d[A-Za-z]{2})|(?:[A-Za-z]{2}\d[A-Za-z] ?\d[A-Za-z]{2})\n")
test_str = ("EC1A 1BB\n"
"W1A 0AX\n"
"M1 1AE\n"
"B33 8TH\n"
"CR2 6XH\n"
"DN55 1PT\n"
"QN55 1PT\n"
"DI55 1PT\n"
"W1Z 0AX\n"
"EC1Z 1BB\n"
"DN55 1CT\n"
"A11A 1AA\n"
"AA11A 1AA\n"
"AA11 1AAA\n"
"AA11 1AAA\n"
"AAA 1AA\n"
"AA 1AA\n"
"A 1AA\n"
"1A 1AA\n"
"1 1AA\n"
"11 1AA\n"
"AA1 1A\n"
"AA1 1\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.