#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[A-Za-z]\d ?\d[A-Za-z]{2})|(?:[A-Za-z][A-Za-z\d]\d ?\d[A-Za-z]{2})|(?:[A-Za-z]{2}\d{2} ?\d[A-Za-z]{2})|(?:[A-Za-z]\d[A-Za-z] ?\d[A-Za-z]{2})|(?:[A-Za-z]{2}\d[A-Za-z] ?\d[A-Za-z]{2})" & @CRLF & _
""
Local $sString = "EC1A 1BB" & @CRLF & _
"W1A 0AX" & @CRLF & _
"M1 1AE" & @CRLF & _
"B33 8TH" & @CRLF & _
"CR2 6XH" & @CRLF & _
"DN55 1PT" & @CRLF & _
"QN55 1PT" & @CRLF & _
"DI55 1PT" & @CRLF & _
"W1Z 0AX" & @CRLF & _
"EC1Z 1BB" & @CRLF & _
"DN55 1CT" & @CRLF & _
"A11A 1AA" & @CRLF & _
"AA11A 1AA" & @CRLF & _
"AA11 1AAA" & @CRLF & _
"AA11 1AAA" & @CRLF & _
"AAA 1AA" & @CRLF & _
"AA 1AA" & @CRLF & _
"A 1AA" & @CRLF & _
"1A 1AA" & @CRLF & _
"1 1AA" & @CRLF & _
"11 1AA" & @CRLF & _
"AA1 1A" & @CRLF & _
"AA1 1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")