import Foundation
let pattern = ##"\b[a-zA-Z1-9]((([]!#$%^&*()])(?!\g<-1>))|[a-zA-Z1-9]){0,63}((?<![]!#$%^&*()])@)(\w+\.)+(com|net|gov|mil|org|edu)\b"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(850)867-5309
850-867-5309
(850_867_5309)
850.867.5309
[Hello]
C:\windows\system32
!MrColdsnow@jimbob.steve.com
BaconTaters@osu.edu
1.2.3.4
11.22.33.44
111.222.111.222
192.168.0.5
1234.1234.1234.1234
956.458.875.259
...
123-45-6789
ABB
ABAB
The quick brown dog jumped over the lazy programmer.
There are fifty states in the United States.
Breathe because RegEx is easy.
42 ( Answer to the Ultimate Question of Life, the Universe, and Everything )
73 (the best number) ( 7 is the 4th prime number and 3 is the 2nd prime number (42) )
(not to mention, 73 is the 21st prime number and 37 is the 12th (both numbers mirrored) and
73 in binary is 1001001 (a palindrome) )
bat cat hat rat brat chat
eat fat gat lat mat oat pat sat vat
my dog likes a good hotdog
dogs like hotdogs but not our "person" dogma
dog
2dog
snoop2dog
10
150
345
14
0789
7980
ICMP echo request
ICMP echo reply
deed peep noon Otto Abba
level kayak madam radar refer civic
redder revver
racecar rotator deified repaper reviver
List of trucks that are better than the F150:
1. GMC Sierra
2. Chevy Silverado
3. Toyota Tundra
4. Nissan Titan
5. Toyota Tacoma
6. GMC Canyon
7. Nissan Frontier
8. Jeep Gladiator
9. Honda Ridgeline
10. Chevy Cavalier
moose mouse mooooose m3se
Mississippi
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)