#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[a-zA-Z1-9]((([]!#$%^&*()])(?!\g<-1>))|[a-zA-Z1-9]){0,63}((?<![]!#$%^&*()])@)(\w+\.)+(com|net|gov|mil|org|edu)\b"
Local $sString = "(850)867-5309" & @CRLF & _
"850-867-5309 " & @CRLF & _
"(850_867_5309)" & @CRLF & _
"850.867.5309" & @CRLF & _
"[Hello]" & @CRLF & _
"C:\windows\system32" & @CRLF & _
"!MrColdsnow@jimbob.steve.com" & @CRLF & _
"BaconTaters@osu.edu" & @CRLF & _
"1.2.3.4" & @CRLF & _
"11.22.33.44" & @CRLF & _
"111.222.111.222" & @CRLF & _
"192.168.0.5" & @CRLF & _
"1234.1234.1234.1234" & @CRLF & _
"956.458.875.259" & @CRLF & _
"..." & @CRLF & _
"123-45-6789" & @CRLF & _
"ABB" & @CRLF & _
"ABAB" & @CRLF & _
"The quick brown dog jumped over the lazy programmer." & @CRLF & _
"There are fifty states in the United States." & @CRLF & _
"Breathe because RegEx is easy." & @CRLF & _
"42 ( Answer to the Ultimate Question of Life, the Universe, and Everything )" & @CRLF & _
"73 (the best number) ( 7 is the 4th prime number and 3 is the 2nd prime number (42) )" & @CRLF & _
" (not to mention, 73 is the 21st prime number and 37 is the 12th (both numbers mirrored) and" & @CRLF & _
" 73 in binary is 1001001 (a palindrome) )" & @CRLF & _
"bat cat hat rat brat chat" & @CRLF & _
"eat fat gat lat mat oat pat sat vat " & @CRLF & _
"my dog likes a good hotdog" & @CRLF & _
"dogs like hotdogs but not our "person" dogma" & @CRLF & _
"dog" & @CRLF & _
"2dog" & @CRLF & _
"snoop2dog" & @CRLF & _
"10" & @CRLF & _
"150" & @CRLF & _
"345" & @CRLF & _
"14" & @CRLF & _
"0789" & @CRLF & _
"7980" & @CRLF & _
"ICMP echo request" & @CRLF & _
"ICMP echo reply" & @CRLF & _
"deed peep noon Otto Abba" & @CRLF & _
"level kayak madam radar refer civic" & @CRLF & _
"redder revver" & @CRLF & _
"racecar rotator deified repaper reviver" & @CRLF & _
"List of trucks that are better than the F150:" & @CRLF & _
"1. GMC Sierra" & @CRLF & _
"2. Chevy Silverado" & @CRLF & _
"3. Toyota Tundra" & @CRLF & _
"4. Nissan Titan" & @CRLF & _
"5. Toyota Tacoma" & @CRLF & _
"6. GMC Canyon" & @CRLF & _
"7. Nissan Frontier" & @CRLF & _
"8. Jeep Gladiator" & @CRLF & _
"9. Honda Ridgeline" & @CRLF & _
"10. Chevy Cavalier" & @CRLF & _
"moose mouse mooooose m3se" & @CRLF & _
"Mississippi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")