$re = '/[(^?&#)]([^=]+)\=([^&#]+)/';
$str = 'https://www.heatingspareparts.com/Boiler-Spares/AllPartsFor/Baxi?Search=a&page=1&more=2#hash';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);